Network packet loss

Frequently Asked Questions

Moderator: Moderators

Network packet loss

Postby nickk » Mon Oct 20, 2008 11:21 am

Network loss due to wireless:
We recommend using a wired network for streaming high-definition video.

Troubleshooting for wireless networks:
If security is enabled on the network, WPA2-AES should be used. WEP, WPA, and TKIP are all broken security-wise, and have worse performance than WPA2-AES on modern hardware.

802.11n routers should be configured in "n only" mode. Backwards compatibility with a/b/g networks degrades performance. All wireless devices connected to the network must support n in order for this to work.

If the router has an option to set channel bandwidth, use the largest setting, typically 40MHz.

If the router supports operation in both the 2.4Ghz and 5GHz bands, try both. 5GHz is less congested and offers better performance in most circumstances, but does not go through walls and floors as well as 2.4GHz does. Bluetooth devices, many cordless phones, and other unlicensed wireless devices that operate on the 2.4GHz band can interfere with wireless network, so avoid using them if at all possible. For cordless phones, use models that operate in the 900MHz or 1.9GHz band, not 2.4GHz.

Try limiting the router to a lower speed than the maximum. Rather than the typical 108Mb/s max for 802.11n, try limiting it to 72 or 54Mb/s operation. While in theory this will limit the maximum performance of the network, the lower speed will enable it to more reliably deliver data at the lower speed, which can actually improve overall performance.

Network loss due to Vista/7/8 network throttling:
http://support.microsoft.com/kb/948066

Windows Vista, 7, and 8 can throttle network performance when using multimedia applications such as Windows Media Center. This can lead to network packet loss when navigating the WMC user interface.

Try disabling this feature by changing the following registry setting to ffffffff (Hexadecimal):
HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Multimedia\SystemProfile\NetworkThrottlingIndex

You will need to reboot after making this change.

Network loss due to the PC network card:
- (WinXP) Right click on My Network Places and choose properties.
- (Win7/8) Go into Control Panel, View network status and tasks, Change adapter settings
- Double click on the Local Area Connection icon to bring up the status page.
- Check that the Speed is reported as 100Mbps or 1Gbps.
- Click Properties. Check the brand/model of the network interface:
-- nForce based interface: Click Configure and switch to the Advanced tab. Disable checksum offloading features.
-- Intel based interface: Click Configure and switch to the Advanced tab. Test with alternative Interrupt Mitigation settings.
-- All interfaces: Click Configure are switch to the Advanced tab. Increase the Receive Buffer size (if this option is present). Test with the Interrupt Mitigation/Moderation setting both On and Off (if this option is present). If the issues persist after adjusting these settings, try disabling all options referencing "offload".

Network loss due to a 3rd party software firewall:
We have seen instances where some 3rd party firewall drivers fail to keep up with streaming HD video over RTP.

As a test, try uninstalling any 3rd party firewall software and rebooting. It is not enough to disable the firewall - it must be uninstalled (disabling typically only affects the rule-set, the firewall driver remains in the data path). In most cases a reboot is required to remove the firewall driver from the network path.

If uninstalling the 3rd party firewall fixes the problem then 1) Try upgrading to the latest version, or 2) contact the firewall vendor, or 3) consider using an alternative firewall such as Windows Firewall.

Network loss in Mac OS X:
Create a file called sysctl.conf in /etc (this must be done as root or using sudo) and add the following lines:
Code: Select all
kern.ipc.maxsockbuf=2097152
net.inet.tcp.sendspace=1048576
net.inet.tcp.recvspace=1048576
net.inet.udp.recvspace=81920
net.inet.udp.maxdgram=65535

Save the file and then reboot the computer.
nickk
Silicondust
 
Posts: 9574
Joined: Tue Jan 13, 2004 9:39 am

Postby jasonl » Mon Oct 03, 2011 2:38 pm

Low level test for network packet loss - ATSC/QAM/DVB:

1) Run HDHomeRun Setup and go into the channel editor. Choose a physical channel number (for example CH102). This is the number before the - in the Tune column.

2) From a cmd prompt run:
"C:\Program Files\Silicondust\HDHomeRun\hdhomerun_config" FFFFFFFF set /tuner0/channel auto:<channel number>
"C:\Program Files\Silicondust\HDHomeRun\hdhomerun_config" FFFFFFFF save /tuner0 null

Replace "<channel number>" with the physical channel number from HDHomeRun Setup (e.g. 102).

If you have more than one HDHomeRun unit then replace "FFFFFFFF" with the device ID of the desired unit.

You should see a series of dots. "n" indicates network packet loss. "t" indicates a reception error. "s" is informational.

Low level test for network packet loss - PRIME:

1) From a cmd prompt run:
"C:\Program Files\Silicondust\HDHomeRun\hdhomerun_config" FFFFFFFF set /tuner0/vchannel <channel number>
"C:\Program Files\Silicondust\HDHomeRun\hdhomerun_config" FFFFFFFF save /tuner0 null

Replace "<channel number>" with the channel number for an unprotected channel in your area.

If you have more than one HDHomeRun unit then replace "FFFFFFFF" with the device ID of the desired unit.

You should see a series of dots. "n" indicates network packet loss. "t" indicates a reception error. "s" is informational.
jasonl
Silicondust
 
Posts: 9267
Joined: Sun Oct 28, 2007 9:23 pm


Return to HDHomeRun DUAL

Who is online

Users browsing this forum: No registered users and 0 guests